Jasypt Java Simplified Encryption Library 1.5.0

org.jasypt
Added: 2009-02-04

Download:

Ivy:

<dependency org="org.jasypt" name="com.springsource.org.jasypt.encryption" rev="1.5.0" />

Maven:

<dependency> <groupId>org.jasypt</groupId> <artifactId>com.springsource.org.jasypt.encryption</artifactId> <version>1.5.0</version> </dependency>

MANIFEST.MF

Import-Bundle: com.springsource.org.jasypt.encryption;version="[1.5.0,1.5.0]"

Libraries (0)

No libraries contain this bundle

Imported Packages (20)

Package Name Version Range Optional?
com.ibm.icu.text [3.4.4, 4.0.0) true
javax.crypto [0.0.0, infinity) false
javax.crypto.spec [0.0.0, infinity) false
javax.servlet [2.4.0, 3.0.0) true
javax.servlet.http [2.4.0, 3.0.0) true
org.acegisecurity.providers.encoding [1.0.0, 2.0.0) true
org.apache.commons.codec.binary [1.1.0, 2.0.0) false
org.apache.commons.lang [2.1.0, 3.0.0) false
org.apache.commons.lang.exception [2.1.0, 3.0.0) false
org.apache.commons.lang.math [2.1.0, 3.0.0) false
org.apache.wicket [1.3.0, 2.0.0) true
org.apache.wicket.util.crypt [1.3.0, 2.0.0) true
org.hibernate [3.2.6.ga, 4.0.0) true
org.hibernate.cfg [3.2.6.ga, 4.0.0) true
org.hibernate.connection [3.2.6.ga, 4.0.0) true
org.hibernate.type [3.2.6.ga, 4.0.0) true
org.hibernate.usertype [3.2.6.ga, 4.0.0) true
org.hibernate.util [3.2.6.ga, 4.0.0) true
org.springframework.beans.factory.config [2.5.4.A, 3.0.0) true
org.springframework.security.providers.encoding [2.0.0.A, 3.0.0) true